Cara Share File di OpenWRT dengan SAMBA Server

Diposting pada

Cara Share File di OpenWRT dengan SAMBA Server. Share File atau membagikan file antar device dalam satu jaringan dapat kita lakukan pada Router OpenWRT. Share File di OpenWRT dapat kita lakukan dengan menggunakan SAMBA Server sebuah software untuk share file dalam satu jaringan Router OpenWRT.

SAMBA Server dapat kita gunakan untuk server penyimpanan file yang dapat kita kelola, seperti edit file dalam satu jaringan Router OpenWRT. Selain itu SAMBA Server juga bisa kita manfaaatkan untuk share File yang kita download menggunakan Aria2 yang sudah saya bahas pada artikel sebelumnya bisa di baca disini.

Dengan menggunakan SAMBA Server membuat kita lebih praktis karena kita dapat mengaksesnya dari PC atau Smartphone tanpa perlu menggunakan USB Flashdisk hanya dengan tersambung jaringan Router OpenWRT yang sama. Cara install SAMBA Server di OpenWRT akan saya bahan dibawah ini.

Cara Share File di OpenWRT dengan SAMBA Server:

Terminal OpenWRT SAMBA Server

  1. Akses terminal OpenWRT dan install SAMBA Server dengan ketikan berikut di terminal.
    opkg update && opkg install luci-app-samba samba36-server ntfs-3g
    
  2. Selanjutnya edit “/etc/config/firewall” dengan cara ketikan perintah berikut.
    nano /etc/config/firewall
    

    Setelah terbuka tambahkan teks setting berikut pada baris terakhir.

    config rule
             option src lan
             option proto udp
             option dest_port 137-138
             option target ACCEPT
    config rule
             option src lan
             option proto tcp
             option dest_port 139
             option target ACCEPT
    config rule
            option src lan
            option proto tcp
            option dest_port 445
            option target ACCEPT
    

    Kemudian tekan CTRL + X lalu ketikan Y untuk Save.

  3. Langkah selanjutnya adalah rubah “/etc/samba/smb.conf.template” agar menjadi dibawah ini. Caranya sama seperti diatas “nano /etc/samba/smb.conf.template”.
    [global]
    netbios name = |NAME|
    display charset = |CHARSET|
    interfaces = |INTERFACES|
    server string = |DESCRIPTION|
    unix charset = ISO-8859-1
    workgroup = |WORKGROUP|
    browseable = yes
    deadtime = 30
    domain master = yes
    encrypt passwords = true
    enable core files = no
    guest account = nobody
    guest ok = yes
    invalid users = root
    local master = yes
    load printers = no
    map to guest = Bad User
    max protocol = SMB2
    min receivefile size = 16384
    null passwords = yes
    obey pam restrictions = yes
    os level = 20
    passdb backend = smbpasswd
    preferred master = yes
    printable = no
    security = share
    smb encrypt = disabled
    smb passwd file = /etc/samba/smbpasswd
    socket options = TCP_NODELAY
    syslog = 10
    use sendfile = yes
    writeable = yes
    
  4. Selanjutnya tambahkan teks berikut pada “/etc/config/samba”.
    config 'samba'
            option 'name' 'openwrt'
            option 'description' 'openwrt'
            option 'workgroup' 'WORKGROUP'
    config 'sambashare'
            option 'read_only' 'no'
            option 'create_mask' '0777'
            option 'dir_mask' '0777'
            option 'name' 'Share'
            option 'path' '/mnt/downloads'
            option 'guest_ok' 'yes'
    

    “/mnt/downloads” adalah lokasi penyimpanan file pada OpenWRT dan bisa kita ganti dengan yang lain.

  5. Selanjutnya tambahkan teks berikut ke “/etc/rc.local”  taruh di atas “exit 0”.
    smbd -D
    nmbd -D
    
  6. Langkah terakhir Start SAMBA Share dengan masukan perintah berikut ke Terminal.
    /etc/init.d/samba enable
    /etc/init.d/samba start
    

SAMBA Share sudah terinstall dan bisa kita akses di Windows pada File Explorer dengan cara ketikan pada address bar “\\192.168.1.1” (alamat Router OpenWRT) maka otomatis akan terbuka Share File di OpenWRT.

Jika pada Windows tidak terbuka mungkin SMB pada Windows belum terinstall, kita bisa Install dengan cara buka Control Panel\All Control Panel Items\Programs and Features dan klik pada Turn Windows features on or off dan centang pada bagian SMB seperti berikut.
Turn Windows features on or off SAMBA Share

Pada Android bisa kita akses dengan aplikasi ES File Explorer Pro.

Demikian tutorial Cara Share File di OpenWRT dengan SAMBA Server, bila ada yang kurang dipahami bisa langsung ditanyakan pada kolom komentar.

Tinggalkan Balasan

Situs ini menggunakan Akismet untuk mengurangi spam. Pelajari bagaimana data komentar Anda diproses.