Cara Install OpenVPN di Router OpenWRT

Cara Install OpenVPN di Router OpenWRT

Diposting pada

OpenVPN merupakan projek Open Source yang dipakai untuk mengamankan jaringan internet. Menggunakan OpenVPN kita dapat menyembunyikan identitas alamat IP kita yang sebenarnya. OpenVPN digunakan agar traffic internet yang kita gunakan lebih secure (aman) dan private lagi.

Pada tutorial sebelumnya saya sudah pernah menjelaskan tentang bagaimana cara Install OpenVPN pada Windows, namun kali ini saya akan menjelaskan cara Install OpenVPN pada Router yang sudah terinstall OpenWRT.

Install OpenVPN di OpenWRT akan membuat seluruh jaringan yang terhubung ke Router akan terproteksi oleh OpenVPN. Menggunakan OpenVPN di OpenWRT kita tidak perlu lagi menggunakan VPN pada device lain saat terhubung dengan Router.

Menginstall OpenVPN di Router OpenWRT sangat mudah, kalian hanya harus akses OpenWRT lewat terminal. Langsung saja saya akan menjelaskan caranya dibawah ini.

Cara Install OpenVPN di Router OpenWRT:

  1. Download dan Install program Putty untuk akses OpenWRT dari terminal.
  2. Buka program Putty dan masukan alamat IP OpenWRT seperti dibawah ini, pilih Open.
    SSH Putty OpenWRT
  3. Selanjutnya masukan username dan password yang diminta.
    Install OpenVPN di OpenWRT
  4. Setelah berhasil masuk terminal OpenWRT masukan perintah berikut untuk install OpenVPN. Pastikan koneksi internet lancar angar proses install berjalan dengan baik.
    opkg update
    opkg install openvpn-openssl
  5. Selanjutnya adalah proses konfigurasi, untuk melakukan konfigurasi membutuhkan program nano, untuk cara install tinggal masukan perntah berikut pada terminal.
    opkg install nano
  6. Proses konfigurasi firewall, untuk konfigurasi firewall OpenVPN masukan perintah berikut
    nano /etc/config/firewall

    tambahakan teks berikut pada akhir config

    config zone
            option name 'openvpn'
            option input 'ACCEPT'
            option forward 'REJECT'
            option output 'ACCEPT'
            option network 'openvpn tunnel'
            option masq '1'
            option mtu_fix '1'
    
    config forwarding
            option dest 'wan'
            option src 'openvpn'
    
    config forwarding
            option dest 'openvpn'
            option src 'lan'

    Simpan config tadi dengan tekan tombol keyboard ctrl + x dan kemudian tekan tombol keyboard Y.
    Setting Firewall OpenWRT

  7. Setelah mengatur firewall untuk OpenVPN selanjutnya mengatur untuk interfacenya, dengan cara masukan perintah berikut
    nano /etc/config/network

    tambahkan teks berikut pada akhir config

    config interface 'openvpn'
            option proto 'none'
            option ifname 'tun0'

    Simpan config tadi dengan tekan tombol keyboard ctrl + x dan kemudian tekan tombol keyboard Y.
    Setting Interface OpenWRT

  8. Sampai disini proses install OpenVPN di OpenWRT sudah selesai dan tinggal menggunakannya, untuk cara menggunakannya akan dibahas pada tutorial selanjutnya.

Demikian tutorial cara install OpenVPN di Router OpenWRT semoga tutorial ini bermanfaat dan untuk cara penggunaannya OpenVPN di OpenWRT akan dibahas pada tutorial selanjutnya. Semoga tutorial ini bermanfaat dan jika ada yang kurang dipahami bisa ditanyan pada kolom komentar dibawah. Terimakasih.

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *

Situs ini menggunakan Akismet untuk mengurangi spam. Pelajari bagaimana data komentar Anda diproses.